originally posted by John Robertson on 16-Sep-09 at 10:15 AM

Over a three day period of pretty intensive hovercraft use (266 miles and 16 hours flying time) a couple of things failed.
Click image for larger version. 

Name:	624.jpg 
Views:	5 
Size:	53.5 KB 
ID:	5549

Firstly, a rudder had an argument with a bush whilst I was backing the trailer around a corner - and the rudder lost!! It was an original rudder made from 3lb cheapo foam and has had a crack in the skin on one side for some time - it folded at the crack oddly enough! I repaired it by bonding a PVC tube up the outside using acrylic adhesive. Time for new rudders I think!

One of the steering cable plastic eyes failed at the rudder end. I use boat control cables (33c) with the plastic sleeve end fittings (Mercury type from memory). I have never had trouble with this before but I am a bit suspicious that the plastic may not be UV stabilised (it's meant to be inside an engine cowling or control box in a boat - not exposed at the back end as in a hovercraft).

Had a couple of small 4" skirt rips (only one needed fixing during the weekend).

The mechanicals all worked fine all weekend - the new belt and pulley covers did their job properly.

I calculated fuel mileage at 10.5mpg over the weekend.

I had the usual skirt-sticking issue on the very smooth water and we also had a very rough return up the east side of lower Loch Fyne one afternoon (Ian B and Trev will verify what the conditions can be like around the Portavadie area ).