Results 1 to 6 of 6

Thread: Help needed

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Newbie Club Member
    Join Date
    Jun 2014
    Posts
    5

    Default Help needed

    Is there anyone in Blackburn area who can help with an engine problem on my Marlin. It's powered by a Briggs and Stratton 35 hp vanguard V twin. It will only tick over on 1 cylinder. But appears to run on both when revs are high. It was running fine a few weeks ago when I was out from knott end. Until the fan blew up. I suspect one of the coils. As both plugs have been replaced. Any advise would be appreciated
    Thanks
    Kevin

  2. #2
    More than 30 posts! Club Member
    Join Date
    Aug 2014
    Posts
    37

    Default Re: Help needed

    Have you checked the valve clearances?


    It probably is the coils, but it wouldn't hurt to make sure the tappets are set correctly.


    Were the spark plugs replaced with new ones?


    How old is the fuel?

  3. #3
    Forum God > 400 posts Club Member
    Join Date
    Mar 2009
    Posts
    978

    Default Re: Help needed

    Did the engine get wet in salt water in the Fan failure incident? Did you manage to clean everything quickly with freshwater immediately afterwards? If not I'd suspect an elecrical fault either in the coils as you suggest or elsewhere in the wiring.

    You could prove which cylinder is failing to run at tickover by taking off plug leads in turn.

    Coming at the prob from another direction if its fine at full revs but lumpy at tickover (rough as apposed to 1 cylinder running) try increasing the tickover speed a bit by adjusting the throttle cable end screws

    Keith
    Last edited by Keith Oakley; 16-Oct-14 at 05:38 AM.

  4. #4
    Newbie Club Member
    Join Date
    Jun 2014
    Posts
    5

    Default Re: Help needed

    Pressure washed it when we got home. Definitely not firing on one barrel properly. Very intermittent. Fuel is new. Both plugs replaced. Swopped coils over last night. And problem changed sides. Engine fitted new at start of year. So should be under warranty but I didn't get any documents when It was delivered this summer. Trying to track the guy down. Does anyone know where the engine number is? I can't find the bloody thing anywhere and I need it to find the correct coil to buy
    Thanks
    Kevin

  5. #5
    More than 10 posts! Club Member
    Join Date
    Mar 2009
    Posts
    22

    Default Re: Help needed

    Kevin,
    The engine no. on a Briggs is usually on the engine cowling near the oil cooler, on a sticker. Have seen it starter motor side on the flywheel cowling too.

    hope that helps.......ish.

    Keith

  6. #6
    Newbie Club Member
    Join Date
    Jun 2014
    Posts
    5

    Default Re: Help needed

    thanks .found engine number on one of those new square bar code thingies.

Similar Threads

  1. more info needed...
    By ctsdesign in forum General Forum
    Replies: 5
    Last Post: 12-Feb-10, 07:43 PM
  2. Help needed
    By eustace007 in forum General Forum
    Replies: 3
    Last Post: 24-Nov-09, 07:40 AM
  3. fan needed 600mm please help
    By chappers69 in forum General Forum
    Replies: 0
    Last Post: 16-Aug-09, 08:56 PM
  4. Generator help needed
    By team black - n/a in forum General Forum
    Replies: 4
    Last Post: 11-Apr-06, 09:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •